English Новый сайт

Расширенный поиск

[ Новые сообщения · Пользователи · Правила ]
Страница 6 из 51«12456785051»
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Разные ошибки, баги, глюки
SpaceEngineerДата: Четверг, 07.04.2011, 00:41 | Сообщение # 1
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Пишите сюда про обнаруженные баги и глюки.

Но перед этим прочитайте про известные ошибки и способы их устранения.

Формат сообщения об ошибке:

1) Словесное описание ошибки и ситуации, при которой она возникла.
2) Характеристики вашей системы: процессор, ОЗУ, видеокарта и объём её памяти.
3) Прикреплённый к сообщению лог-файл. Он находится в папке программы и называется se.log

Вопросы типа "прога не запускается, винда 7, что делать!" не принимаются, т.к. не несут никакой полезной информации. Вопросы без лог-файла не принимаются.


CrabДата: Четверг, 05.05.2011, 22:10 | Сообщение # 76
Первооткрыватель
Группа: Модераторы
Российская Федерация
Сообщений: 444
Награды: 1
Статус: Offline
Может время слишком быстро шло и ты не был синхронизирован с планетой? Тогда планета медленно вращается и приходится генерить новые участки. Так долго не может быть. У меня почти по всем параметрам минимум и генерится при лод 0 масимум минуты 3.

Windows 8 x64
Intel Core2 Duo CPU E7500 2.93GHz.
4 GB RAM.
Nvidia GeForce 550Ti 1024mb.
КесджанДата: Четверг, 05.05.2011, 22:21 | Сообщение # 77
Космический турист
Группа: Пользователи
Российская Федерация
Сообщений: 37
Награды: 0
Статус: Offline
Нет, время нормально идет, стоит real time. Приближаюсь к любой планете - снизу появляется розовая надпись, как я понимаю идет генерация, там меняются разные цифры, при этом все подвисает и курсор и вообще вся система. После 5 минут генерации цифры эти меняются все медленней и медленней, подвтсания длятся по полминуты... Ну я так понимаю не в программе дело, у меня косяк какой-то.
SpaceEngineerДата: Пятница, 06.05.2011, 00:26 | Сообщение # 78
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Вообще-то при LOD 0 всё должно генерироваться от силы секунд 30. Несколько минут - это явно глюк какой-то.
Кесджан, сколько видеопамяти?


SpaceEngineerДата: Пятница, 06.05.2011, 00:29 | Сообщение # 79
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Кстати, по поводу:

Quote (SpaceEngineer)
Вот например тут такого нет: http://www.youtube.com/user/ebruneton#p/a/u/2/BM7Pz7CgTnc При отдалении и приближении плавно все происходит.\

У меня Земля с максимальной детализацией тоже не тормозит и очень быстро грузится (текстуры BMNG, 6 уровень). У него том только карты высот на 2 уровня детальнее, остальное так же. Если ограничить уровень текстур поцедурных планет до 6, они тоже будут полностью успевать подгружаться даже при ЛОД 0 и полёте над поверхностью со скоростью 10-20 км/с. Надо в новом билде будет ввести такую регилировку, плюс сделать её динамической - при большой скорости полёта детализация ограничивается.


КесджанДата: Пятница, 06.05.2011, 07:35 | Сообщение # 80
Космический турист
Группа: Пользователи
Российская Федерация
Сообщений: 37
Награды: 0
Статус: Offline
Quote (SpaceEngineer)
Кесджан, сколько видеопамяти?
512мб видеопамяти, знаю - это минимум, но все равно долго очень sad После минут 10 генерации посередине экрана появляется надпись OUT OF MEMORY, но не вылетает, вчера посмотрел лог, там куча ошибок вконце... Сейчас нет возможности выложить, вечером. Все таки из-за маленького объема vram такое?
G@tchaДата: Пятница, 06.05.2011, 10:57 | Сообщение # 81
Нет аватара
Космический турист
Группа: Пользователи
Соединенные Штаты
Сообщений: 27
Награды: 0
Статус: Offline
Quote (Кесджан)
появляется надпись OUT OF MEMORY

Quote (Кесджан)
из-за маленького объема vram

Да
КесджанДата: Пятница, 06.05.2011, 11:52 | Сообщение # 82
Космический турист
Группа: Пользователи
Российская Федерация
Сообщений: 37
Награды: 0
Статус: Offline
Тогда еще вопрос: для процесса генерации поверхности основной характеристикой видяхи является объем памяти? Частоты особой роли не играют? Это я к тому, что у меня допустим 256 битная видеокарточка с 512мб, если я поставлю 128 битную 1024 гб карту с частотами ниже, чем у моей, все эти процессы ускорятся? Главное память?
SpaceEngineerДата: Пятница, 06.05.2011, 18:07 | Сообщение # 83
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Да, главное память. Частоты влияют на скорость рендера, а на генерацию текстур почти не влияют. Можно включить бенчмарк и посмотреть, за сколько генерятся текстуры цвета и карты высот (последние долго из-за узкого места - передачи в память ЦПУ): f_LoaderBenchmark true в главном конфиге.
Буду переделывать ландшафтный движок, а то такие тормоза не куда не годятся...


ShkolnikДата: Воскресенье, 08.05.2011, 00:51 | Сообщение # 84
Нет аватара
Наблюдатель
Группа: Новички
Беларусь
Сообщений: 1
Награды: 0
Статус: Offline
Здравствуйте. Почему у меня не генерирует ландшафт Земли, Венеры? а с планетами которые далекооо далекоо все норм wacko
CrabДата: Воскресенье, 08.05.2011, 11:57 | Сообщение # 85
Первооткрыватель
Группа: Модераторы
Российская Федерация
Сообщений: 444
Награды: 1
Статус: Offline
Ландшафт земли не генерируется)
Земля стандартна всегда. Качество планет типо Земля, Марс, Венера, всегда похуже зато попроизводительнее.


Windows 8 x64
Intel Core2 Duo CPU E7500 2.93GHz.
4 GB RAM.
Nvidia GeForce 550Ti 1024mb.


Сообщение отредактировал Crab - Воскресенье, 08.05.2011, 11:57
SpaceEngineerДата: Воскресенье, 08.05.2011, 19:05 | Сообщение # 86
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Quote (Shkolnik)
Здравствуйте. Почему у меня не генерирует ландшафт Земли, Венеры? а с планетами которые далекооо далекоо все норм

Вы скачали полную версию 0.93 (300+ мегабайт) или мини версию 0.90 (30 Мб)?


КесджанДата: Понедельник, 09.05.2011, 19:59 | Сообщение # 87
Космический турист
Группа: Пользователи
Российская Федерация
Сообщений: 37
Награды: 0
Статус: Offline
Quote (Кесджан)
Нет, время нормально идет, стоит real time. Приближаюсь к любой планете - снизу появляется розовая надпись, как я понимаю идет генерация, там меняются разные цифры, при этом все подвисает и курсор и вообще вся система. После 5 минут генерации цифры эти меняются все медленней и медленней, подвтсания длятся по полминуты...

Убрал галочку "Rings Shadow on sky" - все стало нормально, ландщафты генерятся за минуту-две... Причем, когда галочка стояла очень медленно генерировались только планеты без атмосферы, пустыни, газовые гиганты, луны, а на планетах с атмосферой процесс проходил быстро. Странно...
Ландшафт земли у меня кстати тоже не рисуется, просто все размыто. Версия 0.93 с атмосферами.


Сообщение отредактировал Кесджан - Понедельник, 09.05.2011, 20:02
SpaceEngineerДата: Понедельник, 09.05.2011, 21:27 | Сообщение # 88
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Не, это странно, Rings Shadow on sky никакаим боком не может влиять на планеты. Оно влияет только на небо.
Так ландшафт у Земли есть, но низкой детализации, или нету вообще (гладкая сфера)? Посмотри какие-нибудь горные районы. Или каньон на Марсе.
Архив с атмосферами нужно качать только если встроенные удалились вместе с кэшем, но не создались автоматически.


КесджанДата: Вторник, 10.05.2011, 18:05 | Сообщение # 89
Космический турист
Группа: Пользователи
Российская Федерация
Сообщений: 37
Награды: 0
Статус: Offline
Quote (SpaceEngineer)
Не, это странно, Rings Shadow on sky никакаим боком не может влиять на планеты. Оно влияет только на небо...

И правда, не вляет Ring Shadows. Вобщем закономерность такая: убираю пару галок любых или ползунок кручу в настройках графики - генерация идет нормально, через минут 10 полетов по планетам начинаются жуткие тормоза (внизу где надписи виснет когда генерится по surface/diff/pos и surface/diff/neg, как-то так), опять захожу в опции, ставлю галки обратно - и чудо, опять все нормально... минут на 10 smile Видимо видеокарта у меня глючит, драйвера пробовал ставить и самы новые и постарее....

Quote (Кесджан)
Так ландшафт у Земли есть, но низкой детализации, или нету вообще (гладкая сфера)?

Ландшафт на Земле есть, очень низкой детализации. На скрине горы северной америки.
Прикрепления: 6329339.jpg(204Kb)


Сообщение отредактировал Кесджан - Вторник, 10.05.2011, 18:19
SpaceEngineerДата: Вторник, 10.05.2011, 19:32 | Сообщение # 90
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Quote (Кесджан)
И правда, не вляет Ring Shadows. Вобщем закономерность такая: убираю пару галок любых или ползунок кручу в настройках графики - генерация идет нормально, через минут 10 полетов по планетам начинаются жуткие тормоза (внизу где надписи виснет когда генерится по surface/diff/pos и surface/diff/neg, как-то так), опять захожу в опции, ставлю галки обратно - и чудо, опять все нормально... минут на 10 Видимо видеокарта у меня глючит, драйвера пробовал ставить и самы новые и постарее....

Ну такое возможно... Я сейчас занимаюсь переработкой системы кэширования данных. Есть шанс, что будущая версия будет стабильной:)

Quote (Кесджан)
Ландшафт на Земле есть, очень низкой детализации. На скрине горы северной америки.

Ну а что вы хотели, Земля же не процедурная, а по реальным насовским текстурам, а установка программы весит всего 350 Мб. У меня есть текстуры Земли в полном разрешении, весят 5 гигов и дают такую картинку:

Потом может выложу этот пак текстур на сайт (после переделки ландшафтного движка). Потом ещё будет процедурное увеличение детализации реальных планет.

Прикрепления: 7960693.jpg(155Kb)


Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Страница 6 из 51«12456785051»
Поиск:

>