English Новый сайт

Расширенный поиск

[ Новые сообщения · Пользователи · Правила ]
Страница 29 из 51«1227282930315051»
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Разные ошибки, баги, глюки
SpaceEngineerДата: Четверг, 07.04.2011, 00:41 | Сообщение # 1
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Пишите сюда про обнаруженные баги и глюки.

Но перед этим прочитайте про известные ошибки и способы их устранения.

Формат сообщения об ошибке:

1) Словесное описание ошибки и ситуации, при которой она возникла.
2) Характеристики вашей системы: процессор, ОЗУ, видеокарта и объём её памяти.
3) Прикреплённый к сообщению лог-файл. Он находится в папке программы и называется se.log

Вопросы типа "прога не запускается, винда 7, что делать!" не принимаются, т.к. не несут никакой полезной информации. Вопросы без лог-файла не принимаются.


SpaceEngineerДата: Среда, 22.02.2012, 22:31 | Сообщение # 421
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Курсор - системный, настройте его в винде.

DukeДата: Четверг, 23.02.2012, 20:53 | Сообщение # 422
Нет аватара
Первооткрыватель
Группа: Команда SE
Антарктика
Сообщений: 419
Награды: 2
Статус: Offline
Появилась возможность потестировать Spaceengine на видеокартах встроенных в процессор Intel Core i5. Программа загружается и начинает рендерить планеты но рельеф не генерируется. В лог сыпется много ошибок насчет некорректного использования framebuffer, хотя на wiki и других сайтах написано что framebuffer в них поддерживается. К сожелению se.log захватить забыл, смогу взять только завтра. Есть ли планы по тестированию Spaceengine на новых картах Intel? Было бы неплохо расширить поддержку оборудования за счет этих видеокарт, так как они будут встроенны практически во все выпускаемые в будущем процессоры Intel.
SpaceEngineerДата: Пятница, 24.02.2012, 00:21 | Сообщение # 423
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Когда у них будет нормальная поддержка float фреймбуфферов, шейдеров 3.0 и прочих прелестей, и главное, будет нормальная производительность - тогда можно будет о чём-то говорить. Знал бы ты, сколько костылей пришлось городить, чтобы SE работал на ATI! Не, NVidia - единственные нормальные карты...

BalogДата: Пятница, 02.03.2012, 00:29 | Сообщение # 424
Исследователь
Группа: Пользователи
Украина
Сообщений: 211
Награды: 0
Статус: Offline
Не знаю в тот ли топик написал и может уже писалось о таком но поиск ничего не дал.
Обратил внимание что у очень многих лун наклон оси строго нулевой. Это ошибка или тому есть физическое объяснение? Ненулевые видел только у самых дальних лун.
SpaceEngineerДата: Пятница, 02.03.2012, 11:41 | Сообщение # 425
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Quote (Balog)
Обратил внимание что у очень многих лун наклон оси строго нулевой. Это ошибка или тому есть физическое объяснение? Ненулевые видел только у самых дальних лун.

Это явление приливной синхронизации.


antimatterДата: Среда, 07.03.2012, 13:49 | Сообщение # 426
Нет аватара
Наблюдатель
Группа: Новички
Российская Федерация
Сообщений: 2
Награды: 0
Статус: Offline
Здравствуйте!
Такая проблема:

  • 1) На планетах поверхность генерируется частично, потом перестаёт. В итоге, после некоторых действий(поворот камеры, перемецение) игры закрывается с ошибкой windows "Прекращена работа 3D Space simulator"
  • 2) CPU: AMD Athlon II x2 3GHz, 4Gb RAM, Palit GTS450 512Mb VRAM(драйвер 295.73). Win7 x64.


Поискал по форуму, была тема с подобными симптомами, но на не открывается. Попробовал рекомендации в FAQ - не помогает.
Прикрепления: 5716358.log(117Kb)


Сообщение отредактировал antimatter - Среда, 07.03.2012, 14:18
SpaceEngineerДата: Среда, 07.03.2012, 14:18 | Сообщение # 427
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
antimatter, это проблема недостатка видеопамяти (у вас 512, доступно всего 466). Я работаю над уменьшением аппетитов движка, а пока попробуйте поотключать процедурные звёзды, 3D воду, облака и т.п., как описано тут: http://spaceengine.org/forum/5-84-1 (открывается?)

antimatterДата: Среда, 07.03.2012, 14:40 | Сообщение # 428
Нет аватара
Наблюдатель
Группа: Новички
Российская Федерация
Сообщений: 2
Награды: 0
Статус: Offline
Спасибо, вроде помогло. Я подозревал, что это из за количества памяти.
ffpДата: Среда, 14.03.2012, 19:22 | Сообщение # 429
Космический пилот
Группа: Пользователи
Российская Федерация
Сообщений: 135
Награды: 0
Статус: Offline
Проблема с коричневым карликом, вращающимся вокруг голубой звезды. И это уже не раз. У других подобных систем было такое.


В логе нашёл ошибку:
ERROR: MemoryManager.CheckMemory(): Can't find oldest star nodes (code 2)
Прикрепления: 8006532.jpg(68Kb) · 9469647.log(31Kb)


Лет эдак через десять, когда SE станет успешным и известным проектом, я буду считаться бородатым олдфагом.

Сообщение отредактировал FORSYTH - Среда, 14.03.2012, 19:48
Dizel777Дата: Среда, 14.03.2012, 19:54 | Сообщение # 430
Строитель Миров
Группа: Модераторы
Российская Федерация
Сообщений: 800
Награды: 4
Статус: Offline
Ого! Звезда такой яркости как голубая зв. должна просвечивать коричневый карлик насквозь! Попробуй убрать галочку "реальная яркость звезд" в настройках графики! Если не поможет, то следующий ответ будет от SpaceEngineerbiggrin

Win 7 Ultimate 64-bit SP1
AMD Phenom II X4 945 Processor
4GB RAM, NVIDIA GeForce GTS 250
ffpДата: Среда, 14.03.2012, 19:56 | Сообщение # 431
Космический пилот
Группа: Пользователи
Российская Федерация
Сообщений: 135
Награды: 0
Статус: Offline
Dizel777, у меня и так не поставлена реальная яркость звёзд.

Лет эдак через десять, когда SE станет успешным и известным проектом, я буду считаться бородатым олдфагом.
SpaceEngineerДата: Четверг, 15.03.2012, 01:09 | Сообщение # 432
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Quote (FORSYTH)
Проблема с коричневым карликом, вращающимся вокруг голубой звезды. И это уже не раз. У других подобных систем было такое.

При освещении звёзд друг другом дополнительная яркость, вызванная нагревом второй звезды, считается честно, по формуле Стефана-Больцмана, но яркость самих звёзд нормируется (если выключена реальная яркость солнца). Если освещённая второй звездой часть поверхности имеет температуру в 2 раза выше, то её яркость выше в 16 раз, и произойдёт пересвечивание. Голубая звезда нагревает коричневый карлик раз в 10, так что яркость становится в 10000 раз больше, и пересвечивание аж чёрный даёт - переполнение где-то в шейдере. Короче это баг, устранить его пока нельзя (разве что шейдер звезды подправить smile )


ПохмёллаДата: Воскресенье, 18.03.2012, 14:19 | Сообщение # 433
Нет аватара
Наблюдатель
Группа: Новички
Пират
Сообщений: 1
Награды: 0
Статус: Offline
При запуске на недавно купленном Samsung NP300V5A столкнулся со следующей проблемой - при включении процедурной генерации звёзд ФПС проседают до 3-4 кадров в секунду (без процедурной держиться на уровне 50-60). Машинка вполне соответствует требованиям. Виной тормозов я подозреваю, что программа грузит только 1 процессор.
Оперативная память 4 гб
Видеокарта 1 гб
Процессор i5 2,4 ггц - 2 ядра (каждое при желании до 3 разгоняется)


Сообщение отредактировал Похмёлла - Воскресенье, 18.03.2012, 14:23
SpaceEngineerДата: Воскресенье, 18.03.2012, 16:30 | Сообщение # 434
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5542
Награды: 54
Статус: Offline
Да, программа однопоточная, но на других машинах таких проблем нет. У меня тоже i5, всё шутро бегает. А проуедурные планеты нормально работают? Покажите лог-файл.

StartrekerДата: Воскресенье, 18.03.2012, 22:03 | Сообщение # 435
Нет аватара
Наблюдатель
Группа: Пользователи
Российская Федерация
Сообщений: 12
Награды: 0
Статус: Offline
У меня при запуске вашей программы постоянно замечаются проблемы с прорисовкой процедурных планет. Система такая: Core i 7 870 (2.9 ггц - а при Hyper-threading-е 3.6 ггц) - 4 ядра. видеокарта GTX 480 (объём видеопамяти 1536 мб) - и оперативной памяти 8 гб DDR 3 1600 мгц. Ос - Windows 8 (превью версия) Дело в том что скриншотов даже близких по красоте к имеющимся на сайте я сделать не могу. Поверхность процедурных планет прорисовывается чудовищно медленно - порою более минуты-двух (если включить Landscape lod 2) а на нуле видно недалеко и плохо. Сама поверхность явно нуждается в сглаживании - к тому же при движении становятся видны какие то чёрные артефакты - заметные даже с орбиты. Вообщем прорисовка очень медленная - и включение отключение функции fast landscape loading эту проблему не решает.) Что вы посоветуете? Такие же тормоза заметны при процедурной генерации звёзд в крупных шаровых скоплениях и в центре галактики. ПО идее железо даже превышает рекомендуемые требования.

Сообщение отредактировал Startreker - Воскресенье, 18.03.2012, 22:05
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Страница 29 из 51«1227282930315051»
Поиск:

>