English Новый сайт

Расширенный поиск

[ Новые сообщения · Пользователи · Правила ]
Страница 10 из 51«12891011125051»
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Разные ошибки, баги, глюки
SpaceEngineerДата: Четверг, 07.04.2011, 00:41 | Сообщение # 1
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5544
Награды: 54
Статус: Offline
Пишите сюда про обнаруженные баги и глюки.

Но перед этим прочитайте про известные ошибки и способы их устранения.

Формат сообщения об ошибке:

1) Словесное описание ошибки и ситуации, при которой она возникла.
2) Характеристики вашей системы: процессор, ОЗУ, видеокарта и объём её памяти.
3) Прикреплённый к сообщению лог-файл. Он находится в папке программы и называется se.log

Вопросы типа "прога не запускается, винда 7, что делать!" не принимаются, т.к. не несут никакой полезной информации. Вопросы без лог-файла не принимаются.


MontesumaДата: Понедельник, 13.06.2011, 13:08 | Сообщение # 136
Первооткрыватель
Группа: Пользователи
Российская Федерация
Сообщений: 539
Награды: 3
Статус: Offline
Хмм, может попробовать GameBooster, он может переводить компьютер в режим, подстроенный для игр???

Если череп смеется - значит у него есть на то причины.
Слова Ванталы
SpaceEngineerДата: Понедельник, 13.06.2011, 14:18 | Сообщение # 137
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5544
Награды: 54
Статус: Offline
Quote (except)
При запуске черный экран и курсор мыши белый в виде плюса. на мышь реагирует. В конфиге только разрешение окна менял. запускаю в окне. Что делать? В логе ничего подозрительного, ошибок не выдает.


Это новый баг, на англ. флруме уже разобрались с ним - надо перейти в фуллскрин (Ctrl-Enter) и обратно. Либо, я полагаю, изменить мышкой размер окна. В логе нет сообщений об ошибках с framebuffer?

Quote (Montesuma)
Ещё наблюдение в свёрнутом виде побыла прога какое-то время не слишком большое, да карточку перегрело и вырубило, итог перезагрузка...


Не может быть... В свёрнутом виде прога переходит в idle режим, ничего не рендерится и проц не юзается...

Quote (Montesuma)
Может переложить хоть часть нагрузки с видео памяти на оперативную или проц (у меня 4 ядра по 2.66 ГГЦ)...???


Нет, "это так не работает", как говорят американцы.

Quote (Aerospacefag)
Вот еще ошибки при пропадании рельефа, из логов.


Да понятно, переполнение памяти идёт. Видеопамять вроде не должна переполняться, значит системная (больше 2 гигов проге не получить) - надо улучшать менеджер памяти.


MrCatДата: Вторник, 14.06.2011, 01:53 | Сообщение # 138
Нет аватара
Наблюдатель
Группа: Новички
Канада
Сообщений: 4
Награды: 0
Статус: Offline
Доброго времени суток.При запуске игры выдает такую вот ошибку :Critical extensions missing:GL_ARB_vertex_array_object. Параметры компьютера :2.80 Ghz cpu,2 Гб озу,карта 9800 gt.Лог файл прикрепил,пожалуйста подскажите в чем проблема.Спасибо.
Прикрепления: 2696906.log(4Kb)


Процесор - AMD Phenom™ 9350 e QUAD-CORE Processor 2.00 GHz
Оперативка - 7 Гб
Видеокарта - Nvidia Geforce GTS 450
Операционка - Win 7 Ultimate x64
SiciliecДата: Вторник, 14.06.2011, 11:12 | Сообщение # 139
Космонавт
Группа: Пользователи
Украина
Сообщений: 47
Награды: 2
Статус: Offline
MrCat, обнови драйвера видеокарты. У тебя старая версия opengl.

Windows 7 x64
DualCore AMD Athlon 4850e, 2625 MHz
ATI Radeon HD 3850, 1Gb
4Gb RAM DDR2


Сообщение отредактировал Siciliec - Вторник, 14.06.2011, 11:14
MrCatДата: Вторник, 14.06.2011, 11:36 | Сообщение # 140
Нет аватара
Наблюдатель
Группа: Новички
Канада
Сообщений: 4
Награды: 0
Статус: Offline
Ясно,спасибо.Буду пробовать. happy

Процесор - AMD Phenom™ 9350 e QUAD-CORE Processor 2.00 GHz
Оперативка - 7 Гб
Видеокарта - Nvidia Geforce GTS 450
Операционка - Win 7 Ultimate x64
G@tchaДата: Вторник, 14.06.2011, 16:48 | Сообщение # 141
Нет аватара
Космический турист
Группа: Пользователи
Соединенные Штаты
Сообщений: 27
Награды: 0
Статус: Offline
Скачал последнюю версию и не могу запустить игру.
В самом конце загрузки, когда уже появляется окно игры - вылетает:
Code
Инструкция по адресу 0x004994ac обратилась к памяти по адрсу 0x0000000e. Память не может быть read.

Изменения конфигов (отключил всё, что можно) ничего не дали.

ЗЫ: только что установил, что игра нормально запускается из архива (открытого 7z или winRAR), но наотрез отказывается запускаться в распакованном любым из этих двух архиваторов виде. Пробовал распаковывать на разные диски, везде один результат.


Сообщение отредактировал G@tcha - Вторник, 14.06.2011, 17:01
XentДата: Вторник, 14.06.2011, 17:59 | Сообщение # 142
Нет аватара
Наблюдатель
Группа: Пользователи
Российская Федерация
Сообщений: 17
Награды: 0
Статус: Offline
У меня вопросец. Сейчас 1280 Мб видеопамяти, если поставить карточку с 3Гб, то проблема с вылетами в центрах галактик и посадках на планеты исчезнет или нет. Еще вопрос по поводу SLI - есть ли поддержка и добавит ли это память...скажем 3+3=6 или 3?
Digit1990Дата: Вторник, 14.06.2011, 18:01 | Сообщение # 143
Исследователь
Группа: Администраторы
Российская Федерация
Сообщений: 260
Награды: 0
Статус: Offline
Чудеса в решете - у меня при запуске из архива перестали мерцать текстуры!
И вообще - судя по инф. строке - все стало быстро подгружаться!

А всего лишь - запуск из temp папки rar-архиватора.

---
Попробовал переместить папку с программой на системный диск. Глюков явно стало меньше.


Per aspera ad Astra
MontesumaДата: Вторник, 14.06.2011, 18:57 | Сообщение # 144
Первооткрыватель
Группа: Пользователи
Российская Федерация
Сообщений: 539
Награды: 3
Статус: Offline
Quote (Xent)
У меня вопросец. Сейчас 1280 Мб видеопамяти, если поставить карточку с 3Гб, то проблема с вылетами в центрах галактик и посадках на планеты исчезнет или нет. Еще вопрос по поводу SLI - есть ли поддержка и добавит ли это память...скажем 3+3=6 или 3?


Хмм, у меня 512 мб и в этих случаях вылетов нет... Только с астероидами гладкими...

Quote (Digit1990)
Чудеса в решете - у меня при запуске из архива перестали мерцать текстуры! И вообще - судя по инф. строке - все стало быстро подгружаться! А всего лишь - запуск из temp папки rar-архиватора.


Интересно, тоже попробую из архива...

Добавлено (14.06.2011, 18:57)
---------------------------------------------
Проверил, подтверждаю при запуске из архива всё грузиться быстрее (fps больше) и программа работает лучше и безглючнее... Изчезла даже бесконечная загрузке мешей и текстур на Апофизе...

Одна проблема как теперь скрины делать?


Если череп смеется - значит у него есть на то причины.
Слова Ванталы
CrabДата: Вторник, 14.06.2011, 21:02 | Сообщение # 145
Первооткрыватель
Группа: Модераторы
Российская Федерация
Сообщений: 444
Награды: 1
Статус: Offline
F11- делать скрины...

Windows 8 x64
Intel Core2 Duo CPU E7500 2.93GHz.
4 GB RAM.
Nvidia GeForce 550Ti 1024mb.
MontesumaДата: Вторник, 14.06.2011, 21:11 | Сообщение # 146
Первооткрыватель
Группа: Пользователи
Российская Федерация
Сообщений: 539
Награды: 3
Статус: Offline
Quote (Crab)
F11- делать скрины...


Это я знаю и сохраняются в спец папку, но когда из архива запускаешь куда они будут сохраняться???


Если череп смеется - значит у него есть на то причины.
Слова Ванталы
SpaceEngineerДата: Вторник, 14.06.2011, 22:25 | Сообщение # 147
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5544
Награды: 54
Статус: Offline
Quote (G@tcha)
ЗЫ: только что установил, что игра нормально запускается из архива (открытого 7z или winRAR), но наотрез отказывается запускаться в распакованном любым из этих двух архиваторов виде. Пробовал распаковывать на разные диски, везде один результат.


Да уж, это что-то новенькое... Может архив битый?

Quote (Xent)
У меня вопросец. Сейчас 1280 Мб видеопамяти, если поставить карточку с 3Гб, то проблема с вылетами в центрах галактик и посадках на планеты исчезнет или нет. Еще вопрос по поводу SLI - есть ли поддержка и добавит ли это память...скажем 3+3=6 или 3?


Вылетов в центре галактик вроде и так нет. Если поставить 3 Гб видеопамяти, вылеты будут, но теперь из-за переполнения системной памяти. SE - приложение 32-битное, и больше 2 Гб опреативы получить не может. А в текущей версии менеджер памяти вообще не следит за оперативой. Я наоборот советую тем, у кого много видеопамяти (1280 и боьльше), ограничить её использование движком - тогда и и данных в оперативе будет меньше 2 Гб, т.к. кэш будет своевременно очищаться.

Я создал тему по багам версии 0.94: http://spaceengine.org/forum/5-35-1#802

См. пункт 4e). Это называется перестарался с оптимизацией расхода видеопамяти))) Что ж, в новой версии исправлю.

Насчёт SLI понятия не имею. У меня одиночная карта GF 9800 CTX, да ещё мамка заточена под атишый CrossFire, а не SLI. По идее все тонкости работы системы в SLI скрыты от программиста - это просто получается как бы мощная видюха с 6 Гб памяти. Попробуйте запустить движок на SLI, мне самому интересно. Если в начале лога будет написано

Total video memory: 6144 Mb

- значит действительно всё просто:)


XentДата: Вторник, 14.06.2011, 23:32 | Сообщение # 148
Нет аватара
Наблюдатель
Группа: Пользователи
Российская Федерация
Сообщений: 17
Награды: 0
Статус: Offline
Спасибо. Поставил 60% видеопамяти и реально помогло - теперь почти никогда не вылетает.
G@tchaДата: Среда, 15.06.2011, 07:27 | Сообщение # 149
Нет аватара
Космический турист
Группа: Пользователи
Соединенные Штаты
Сообщений: 27
Награды: 0
Статус: Offline
Quote (SpaceEngineer)
Да уж, это что-то новенькое... Может архив битый?

Разве что архив, выложенный на сайте. Скачал уже 3 раза и всегда одно и то же.
Правда, 1 раз игра всё-таки запустилась из папки, но при этом был глюк с разноцветными прямоугольниками вместо надписей, указателя мыши и другого текста и не отображающимися текстурами/мешами поверхностей (при подлёте к планете они даже не начинают грузиться), а через пару минут игра просто закрылась без всяких сообщений об ошибке.
При запуске из архива - опять всё ОК.
ЗЫ предыдущая версия работает без всяких ошибок
ЗЫ2: у меня одного так странно сгенерировались звёзды в этом скоплении?
При попытке подлететь игра виснет от количества звёзд, там их плотность раза в 3 выше, чем в центре Млечного Пути.
Что странно, все звёзды там - гиганты.
Прикрепления: 5187665.jpg(144Kb) · 4845586.jpg(199Kb)


Сообщение отредактировал G@tcha - Среда, 15.06.2011, 15:22
КесджанДата: Среда, 15.06.2011, 15:08 | Сообщение # 150
Космический турист
Группа: Пользователи
Российская Федерация
Сообщений: 37
Награды: 0
Статус: Offline
Quote (miros_0571)
У меня видеокарта NVDIA GeForce GTX 260, процессор Intel Pentium 4 и ОС Windows 7 Service Pack 1.
Как настроить чтобы программа работала нормально ?

Ничего настраивать не надо, она итак нормально работает smile
Вы бы поподробней писали в чем проблема. А так получается: у меня машина 10ка, не ездит чето, как сделать чтобы ездила?))


Сообщение отредактировал Кесджан - Среда, 15.06.2011, 15:10
Форум » SpaceEngine » Проблемы и их решения » Разные ошибки, баги, глюки (Обсуждение ошибок в работе программы и путей их решения)
Страница 10 из 51«12891011125051»
Поиск:

>