English Новый сайт

Расширенный поиск

[ Новые сообщения · Пользователи · Правила ]
Страница 9 из 90«1278910118990»
Форум » SpaceEngine » Архив » Состояние разработки и публичный бета тест 0.9.7.4
Состояние разработки и публичный бета тест 0.9.7.4
EchoTangoДата: Воскресенье, 31.05.2015, 23:32 | Сообщение # 121
Исследователь
Группа: Пользователи
Пират
Сообщений: 238
Награды: 4
Статус: Offline
Две проблемы.
Первая: пропадают звезды.
Ситуация: режим управления кораблем (скайлон), на низкой орбите, безатмосферного тела.
Если геометрический центр корабля располагается на фоне планеты, то звезды пропадают. Если на фоне космоса, то появляются.
Режим автоэкспозиции отключен.
Обратил внимание, что резко меняется число StarNodes и StarLeafs с 300-400 до 12-15.

Вторая: тормоза.
Начинаются если переключить PointSources -> Stars в режим точек. Пропадают тормоза в режиме Motion Blur.

Добавлено (31.05.2015, 23:19)
---------------------------------------------
А также, если переставить ползунок Bloom больше ноля, то при повороте камеры, вокруг источников света, ВРЕМЕННО появляются черные квадраты, с закругленными углами, обрамленные белым кантом.
Такой же белый кант появляется на силуэте корабля (скайлон).

Добавлено (31.05.2015, 23:32)
---------------------------------------------
Дополнение к первому пункту:
Звезды (и Млечный Путь) пропадают не всегда, но только, если в поле видимости находится орбита/орбиты спутников планеты (орбита желтого цвета, уходящая за горизонт)!
Блин. Тестировал сейчас с разных ракурсов. Не всегда это происходит. Не могу поймать закономерность.


Сообщение отредактировал EchoTango - Воскресенье, 31.05.2015, 23:37
ВольвоксДата: Воскресенье, 31.05.2015, 23:44 | Сообщение # 122
Исследователь
Группа: Пользователи
Российская Федерация
Сообщений: 241
Награды: 1
Статус: Offline
Запустил планетарий с пробным пачтем. Количество зависаний прктически равно нулю, особых проблем не вижу, но:
1)При вкючении режима "Взять управление" в меню планетной системы объекты начинают мигать.
2)В Вики свет от двигателей кораблей отображается яркими бликами.
В остальном всё идеально. Даже выключал в ручную. smile
EchoTangoДата: Воскресенье, 31.05.2015, 23:47 | Сообщение # 123
Исследователь
Группа: Пользователи
Пират
Сообщений: 238
Награды: 4
Статус: Offline
Не уверен: такой же эффект наблюдается (звезды пропадают), если в поле зрения находится центр галактики, или светило.
SpaceEngineerДата: Понедельник, 01.06.2015, 19:03 | Сообщение # 124
Автор Space Engine
Группа: Администраторы
Российская Федерация
Сообщений: 5544
Награды: 54
Статус: Offline
Rutkovich, EchoTango, Вольвокс, это всё последствия бага с бесконечной температурой некоторых селен.

Цитата yahorizon2011 ()
Тормоза и лаги у планет и на планетах практически исчезли! Над данный момент оптимизация отличная! Yes!

Это не оптимизицая, и настройка Loader timing 2 по умолчанию.


RutkovichДата: Понедельник, 01.06.2015, 19:50 | Сообщение # 125
Нет аватара
Космонавт
Группа: Пользователи
Российская Федерация
Сообщений: 77
Награды: 0
Статус: Offline
Цитата SpaceEngineer
это всё последствия бага с бесконечной температурой некоторых селен.
Это стало происходить и с другими планетами...
По моему что-то не так с автоэкспозицией
RomFilДата: Понедельник, 01.06.2015, 19:53 | Сообщение # 126
Нет аватара
Строитель Миров
Группа: Пользователи
Пират
Сообщений: 705
Награды: 2
Статус: Offline
SpaceEngineer, а как насчёт "сложности при рендере" и моего поста выше?
lexancccpДата: Понедельник, 01.06.2015, 20:30 | Сообщение # 127
Нет аватара
Исследователь
Группа: Пользователи
Пират
Сообщений: 268
Награды: 0
Статус: Offline
как быть с резким поведением кораблей в режимах автопилота? где можно это явление подправить?
yahorizon2011Дата: Вторник, 02.06.2015, 02:23 | Сообщение # 128
Строитель Миров
Группа: Пользователи
Пират
Сообщений: 793
Награды: 2
Статус: Offline
Цитата SpaceEngineer ()
Это не оптимизицая, и настройка Loader timing 2 по умолчанию.

Ну у меня стоит 9. Я имел ввиду с этой установкой. )


Phenom IIx6 3870 МГц; Radeon HD 7870 OC 2048 Мб; RAM 6 Гб; Win 7 64, видеодрайвер Radeon 16.4.1

"И страшным, страшным креном
к другим каким-нибудь
неведомым вселенным
повернут Млечный Путь."
EchoTangoДата: Вторник, 02.06.2015, 21:22 | Сообщение # 129
Исследователь
Группа: Пользователи
Пират
Сообщений: 238
Награды: 4
Статус: Offline
Не баг, а вопрос:
заметил, что при наличии ускорения, камера смещается назад, в зависимости от этого самого ускорения.
При вращении камеры вокруг корабля, обнаружил, что камера смещается не методом увеличения дистанции от точки поворота до камеры, а путем смещения этой самой точки поворота в кормовую часть корабля, и за его пределы.
От этого вращение камеры вокруг пустого места выглядит неестественно.
Может стоит увеличивать дистанцию ось-камера а не ось-центр корабля?
lexancccpДата: Вторник, 02.06.2015, 21:55 | Сообщение # 130
Нет аватара
Исследователь
Группа: Пользователи
Пират
Сообщений: 268
Награды: 0
Статус: Offline
жесткий краш
лог: https://www.sendspace.com/file/ykgf0k
что то не то все же с кораблями
EchoTangoДата: Вторник, 02.06.2015, 22:10 | Сообщение # 131
Исследователь
Группа: Пользователи
Пират
Сообщений: 238
Награды: 4
Статус: Offline
Прямо сейчас Скайлон нарезает круги за пределами атмосферы довольно массивной океаниды с тремя серьезными спутниками и кольцом.
Включен режим "Horizon" (Горизонтальный полет?).
Время от времени срабатывают маневровые сопла, синими сполохами. Корабль плавно держит горизонт. Только что прошел линию терминатора. Под крылом клубятся белесые облака.

Резких рывков не наблюдаю.
Наблюдаю кольцо поверх Скайлона, время от времени. Но рывков нет.
А вы на каком корабле тестите? У вас маневровые двигатели симметрично расположены?
Может это проблема треугольников/шестиугольников?


Сообщение отредактировал EchoTango - Вторник, 02.06.2015, 22:11
lexancccpДата: Среда, 03.06.2015, 12:47 | Сообщение # 132
Нет аватара
Исследователь
Группа: Пользователи
Пират
Сообщений: 268
Награды: 0
Статус: Offline
нууу на скайлоне может и все ровно в режиме автопилота, но вот звездолеты это обзац, дерганые в полный рост. летаю на звездолетах biggrin
EchoTangoДата: Среда, 03.06.2015, 13:22 | Сообщение # 133
Исследователь
Группа: Пользователи
Пират
Сообщений: 238
Награды: 4
Статус: Offline
А как на ваших звездолетах расположены маневровые двигатели?
Расположены ли они симметрично?
Куда направлены дюзы?

Я как-то сделал миниатюрный звездолет с помощью местного редактора кораблей.
Корабль строился с тремя несущими балками, тремя топливными баками вокруг единственного двигателя.
Ну, и маневровые двигатели, тоже треугольником разместил.
Пока использовал SE 0.9.3, корабль управлялся нормально. В тестовой версии появился выхлоп из дюз, и вероятно, тяга.
Корабль стал кувыркаться беспорядочно, от любой попытки развернуть его.
Так, что проанализируйте расположение маневровых двигателей, их парность, симметрию.
Возможно в этом все дело.
lexancccpДата: Среда, 03.06.2015, 14:05 | Сообщение # 134
Нет аватара
Исследователь
Группа: Пользователи
Пират
Сообщений: 268
Награды: 0
Статус: Offline
значит встретил новый для себя баг

занятно выглядит
то что корабли в режимах автопилота с ума сходят тут походу надо инженеру колдовать


Сообщение отредактировал lexancccp - Среда, 03.06.2015, 14:07
RattusДата: Среда, 03.06.2015, 14:54 | Сообщение # 135
Строитель Миров
Группа: Модераторы
Российская Федерация
Сообщений: 663
Награды: 4
Статус: Offline
Цитата lexancccp ()
занятно выглядит
[off]Так вот ты какое - Небо в алмазах. rolleyes [/off]


"Ннапыльн%х тpапинкахъ далиокихъ плонеттъ астануцца нашшы погадкиъ!" (ЙожЪ)
Форум » SpaceEngine » Архив » Состояние разработки и публичный бета тест 0.9.7.4
Страница 9 из 90«1278910118990»
Поиск:

>